package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[(+1]`)
var str = `(541) 754-3010
+1-541-754-3010
1-541-754-3010
(541) 754 3010
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}