$re = '/Py[tho]/m';
$str = 'Python language
python algorithm
code Pyhon
Pyon script
more repetitions Pyththththtthon
zero occurrences Py Pyttt-pyPyth';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);