$re = '/Pyt?/m';
$str = 'Python language
python algorithm
code Python
Python script
more repetitions Pyttttthon
zero occurrences Py Py-pyPy ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);