package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{2}\.\d{2}\.\d{4}\b`)
var str = `01.01.2021 05.10.2015 01.01.2111 12345 001 Text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}