#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)NAME\s+(\S.*?)\s+FISCAL\b"
Local $sString = "NAME MARY POPPINS FISCAL 20394" & @CRLF & _
"NAME MARY JANE POPPINS FISCAL 20394" & @CRLF & _
"NAME SNOWFLAKE INC. FISCAL 20394" & @CRLF & _
"NAME FISCAL 20394"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")