package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)NAME\s+(\S.*?)\s+FISCAL\b`)
var str = `NAME MARY POPPINS FISCAL 20394
NAME MARY JANE POPPINS FISCAL 20394
NAME SNOWFLAKE INC. FISCAL 20394
NAME FISCAL 20394`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}