using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=\S)( )+)? *remove *(?(1) (?=\S)(?!remove\b))";
string substitution = @"\1";
string input = @"before remove after
before remove after
remove after
before remove
before remove
remove
remove
remove
before remove after remove before
before remove after remove before remove
before remove after remove before remove
before remove after remove before before remove remove remove
remove remove remove ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}