import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<=\\S)( )+)? *remove *(?(1) (?=\\S)(?!remove\\b))";
final String string = "before remove after\n"
+ "before remove after\n"
+ "remove after\n"
+ "before remove\n"
+ "before remove\n"
+ "remove\n"
+ " remove \n"
+ "remove \n"
+ "before remove after remove before\n"
+ "before remove after remove before remove\n"
+ "before remove after remove before remove \n"
+ "before remove after remove before before remove remove remove\n"
+ "remove remove remove ";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}