package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)((\[.*\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\$?[a-z]{1,3}\$?[0-9]{1,7})(\:\$?[a-z]{1,3}\$?[0-9]{1,7})?|\$?[a-z]{1,3}\:\$?[a-z]{1,3}|\$?[0-9]{1,7}\:\$?[0-9]{1,7})`)
var str = `A1:B1
A$1:B$12
$A1:$b12
AA11:$BB$11
$A:B
A:$C
12:34
$12:$35
'hello'+[ths]ToDoList_1!D26+'Blank ''A1''(2)'!G14
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}