use strict;
my $str = 'A1:B1
A$1:B$12
$A1:$b12
AA11:$BB$11
$A:B
A:$C
12:34
$12:$35
\'hello\'+[ths]ToDoList_1!D26+\'Blank \'\'A1\'\'(2)\'!G14
';
my $regex = qr/((\[.*\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\$?[a-z]{1,3}\$?[0-9]{1,7})(\:\$?[a-z]{1,3}\$?[0-9]{1,7})?|\$?[a-z]{1,3}\:\$?[a-z]{1,3}|\$?[0-9]{1,7}\:\$?[0-9]{1,7})/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}