import re
regex = re.compile(r"((\[.*\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\$?[a-z]{1,3}\$?[0-9]{1,7})(\:\$?[a-z]{1,3}\$?[0-9]{1,7})?|\$?[a-z]{1,3}\:\$?[a-z]{1,3}|\$?[0-9]{1,7}\:\$?[0-9]{1,7})", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("A1:B1\n"
"A$1:B$12\n"
"$A1:$b12\n"
"AA11:$BB$11\n\n"
"$A:B\n"
"A:$C\n"
"12:34\n"
"$12:$35\n\n"
"'hello'+[ths]ToDoList_1!D26+'Blank ''A1''(2)'!G14\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")