// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)((\[.*\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\$?[a-z]{1,3}\$?[0-9]{1,7})(\:\$?[a-z]{1,3}\$?[0-9]{1,7})?|\$?[a-z]{1,3}\:\$?[a-z]{1,3}|\$?[0-9]{1,7}\:\$?[0-9]{1,7})").unwrap();
let string = "A1:B1
A$1:B$12
$A1:$b12
AA11:$BB$11
$A:B
A:$C
12:34
$12:$35
'hello'+[ths]ToDoList_1!D26+'Blank ''A1''(2)'!G14
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}