import Foundation
let pattern = #"((\[.*\])?(('(?:[^']|'')*'!)|([a-zA-Z0-9_]+!)))?((\$?[a-z]{1,3}\$?[0-9]{1,7})(\:\$?[a-z]{1,3}\$?[0-9]{1,7})?|\$?[a-z]{1,3}\:\$?[a-z]{1,3}|\$?[0-9]{1,7}\:\$?[0-9]{1,7})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
A1:B1
A$1:B$12
$A1:$b12
AA11:$BB$11
$A:B
A:$C
12:34
$12:$35
'hello'+[ths]ToDoList_1!D26+'Blank ''A1''(2)'!G14
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)