package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/\/\*\*`)
var str = `//**
******************************************************************************************
*
******************************************************************************************
*/
ModbusArray[0].Data = (int*) &LoopTime; // рег.0 Максиальный цикл программы
ModbusArray[0].WriterLock = RECORDING_IS_PROHIBITED;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}