package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})_(\d{2})_(\d{2})_(.*).md`)
var str = `2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md`
var substitution = "$1/$2/$4/index.md"
fmt.Println(re.ReplaceAllString(str, substitution))
}