// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4})_(\d{2})_(\d{2})_(.*).md").unwrap();
let string = "2005_03_19_this_is_the_filename.md
2007_07_23_another_filename.md
2021_01_12_filename.md";
let substitution = "$1/$2/$4/index.md";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}