#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=[a-z0-9]{2,5}$)(?=.*[a-z])(?=.*[0-9])(?!(?:.*[a-z]){4})[a-z0-9]+$"
Local $sString = "4dse4" & @CRLF & _
"d4" & @CRLF & _
"4d" & @CRLF & _
"34d" & @CRLF & _
"34d4" & @CRLF & _
"34dd" & @CRLF & _
"d44d" & @CRLF & _
"dd5d" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"44" & @CRLF & _
"dd" & @CRLF & _
"222" & @CRLF & _
"2222" & @CRLF & _
"ddd" & @CRLF & _
"dddd" & @CRLF & _
"4dse434353353" & @CRLF & _
"ddddd" & @CRLF & _
"44444" & @CRLF & _
"dddd4" & @CRLF & _
"dd4df"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")