using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\x{4E00}-\x{9FA5}a-z0-9_-]{3,6}$";
string input = @"fhg中文";
RegexOptions options = RegexOptions.CultureInvariant;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}