re = /python.*$/m
str = '/opt/homebrew/bin/python3
/usr/local/bin/python3
/usr/bin/python3
/usr/local/bin/python3.9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end