const regex = /Feature: (?!(Hatseflats|Bananas|Frappadingue)).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Feature: (?!(Hatseflats|Bananas|Frappadingue)).*', 'g')
const str = `Feature: Hatseflats/Core/Service management - Timestamp transition
Feature: Bananas/Core/Service management - Timestamp transition
Feature: Frappadingue/Core/Service management - Timestamp transition
Feature: Timestamp transition
Feature: Blablabla
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}