package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^[:alnum:]\-_]`)
var str = `tesTStriNg%&/()=?aj-hd_86b`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}