$re = '/(["\'`])(?:(?=(\\\\?))\2.)*?\1/ms';
$str = 'ggg, "hhh"
ggg
"hhh
hhhh"
...
"hh\\"x\\"jj"
...
"%d=\\"hi
hi\\"oh"
`gg"g"
\\" `
`Hello "My
friend"
`
\'bbb\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);