re = /(["'`])(?:(?=(\\?))\2.)*?\1/m
str = 'ggg, "hhh"
ggg
"hhh
hhhh"
...
"hh\\"x\\"jj"
...
"%d=\\"hi
hi\\"oh"
`gg"g"
\\" `
`Hello "My
friend"
`
\'bbb\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end