$re = '/(.+)(((and|or)\s+)?)+/i';
$str = 'test1 test2 and test2 or test4 test5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);