package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+(98|0)?9\d{9}`)
var str = `sdas+98917292912365`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}