using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^Кому-то понравилась твоя анкета(:|\(и еще \d+\))?\n\n(.+?), (\d+), (.+?)( – ([\s\S]+?))?(\n\nСообщение для тебя💌: ([\s\S]+))?$";
        string input = @"Кому-то понравилась твоя анкета:
Матвей, 18, 📍3 км";
        
        Match m = Regex.Match(input, pattern);
        Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
    }
}