Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^Кому-то понравилась твоя анкета(:|\(и еще \d+\))?\n\n(.+?), (\d+), (.+?)( – ([\s\S]+?))?(\n\nСообщение для тебя💌: ([\s\S]+))?$
/
Test String
New
Кому-то понравилась твоя анкета: Матвей, 18, 📍3 км