using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\P{L}*\p{Script=Cyrl}";
string input = @"lalala Ф
1123 Щ
1-1+2.3!! Щ
1s-1+2.3!! Щ";
RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}