// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)^\P{L}*\p{Script=Cyrl}").unwrap();
let string = "lalala Ф
1123 Щ
1-1+2.3!! Щ
1s-1+2.3!! Щ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}