using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Arvada( [a-zA-Z]+){0,4}[,\.] [A-Z]{2}";
string input = @"City of Arvada\n\nRevenue Division\nArvada, CO 80001\n other random words";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}