package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Arvada( [a-zA-Z]+){0,4}[,\.] [A-Z]{2}`)
var str = `City of Arvada\n\nRevenue Division\nArvada, CO 80001\n other random words`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}