#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(.+)(?:\n.*)(?:relatora?|desembargadora?|ju[íi]za?)"
Local $sString = "2. dispositivo" & @CRLF & _
"" & @CRLF & _
"luiza carla g. godoi" & @CRLF & _
" juíza" & @CRLF & _
"" & @CRLF & _
"acordam os magistrados da 2ª turma do " & @CRLF & _
"tribunal regional do trabalho da 2ª região em: não " & @CRLF & _
"na forma da " & @CRLF & _
"do agravo de instrumento, " & @CRLF & _
"" & @CRLF & _
"luiz carlos g. godoi" & @CRLF & _
" desembargador" & @CRLF & _
"" & @CRLF & _
"conhecer " & @CRLF & _
"" & @CRLF & _
"fundamentação do voto do relator." & @CRLF & _
"" & @CRLF & _
"luiz carlos g. godoi" & @CRLF & _
" relator" & @CRLF & _
"" & @CRLF & _
"§01918.2007.501.02.01-0 (brl53010)" & @CRLF & _
"" & @CRLF & _
"documento elaborado e assinado em meio digital. validade legal nos termos da lei n. 11.419/2006.(cid:13)" & @CRLF & _
"disponibilização e verificação de autenticidade no site www.trtsp.jus.br informando:" & @CRLF & _
"codigo do documento = 10017" & @CRLF & _
"" & @CRLF & _
"luiza carla g. godoi" & @CRLF & _
" relatora" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"reclamada da ação trabalhista julgada " & @CRLF & _
"procedente em parte, está a agravante legitimada à " & @CRLF & _
"impugnação." & @CRLF & _
"" & @CRLF & _
"luiza carla g. godoi" & @CRLF & _
" desembargadora" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")