import Foundation
let pattern = #"[A-Z]{3}(?=\.)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/path/to/QAQC/Conclusions_Pakistan_2019-09-13_PAK.pdf
/path/to/QAQC/Conclusions_SouthAfrica_2019-09-13_ZAF.pdf
/path/to/QAQC/Conclusions_TheBahamas_2019-09-13_BHS.pdf
/path/to/QAQC/Conclusions_Venezuela_2019-09-13_VEN.pdf
/path/to/QAQC/Conclusions_Pakistan_2019-09-13_YEM.pdf
/path/to/QAQC/Conclusions_Iraq_2019-09-13_IRQ.pdf
/path/to/QAQC/Conclusions_Afghanistan_2019-09-13_AFG.pdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)