$re = '/(s1)(((?!s1|s2)(.|\n))*)(s2)/mu';
$str = 's1
s2
s1
s1
s2
s2
s1
s1
s2
s2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);