package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[A-Z][a-z]\.|\w\.\w.|.)*?[.!?])(?:\s+|$)`)
var str = `Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}