using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!www.(?:abc|def).test.com)(?=www.*\.test\..*com)^.+$";
string input = @"www.test.com
www.abc.test.com
www.def.test.com
www.ghi.test.com
www.nottest.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}