use strict;
my $str = '"AbCd1234|99999"';
my $regex = qr/\"([^|]+)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";