import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+D )\\d{4}";
final String string = "Priority Controller DB8009 120D 4312\n"
+ "Priority Controller DB8009 120D 4312\n"
+ "Priority Controller DB8008 130D 4000\n"
+ "Priority Controller DB8009 110D 4222\n"
+ "Priority Controller DB8008 120D 3000\n"
+ "Priority Controller DB8009 120D 2000\n"
+ "Priority Controller DB8009 110D 6003";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}