import re
regex = re.compile(r'(?P<ip>\S*) (?P<firstseperator>-) (?P<userid>\S+|-) (?P<timestamp>\[\S+ \S+) "(?P<URL>\S+|\S+ \S+ [A-Z/0-9.]+)" (?P<http_code>[0-9]+) (?P<guessing_size>[0-9]+) "(?P<endpoint_url>\S+|-)" "(?P<client_and_version>[a-zA-Z/0-9.-]+)', flags=re.MULTILINE)
test_str = "192.241.202.20 - - [22/Mar/2023:05:31:42 +0000] \"SSH-2.0-Go\" 400 157 \"-\" \"-\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")