#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xa)(?mixs)1-ASCII:(?#Literales ASCII)\n" & @CRLF & _
"1\.1-Los\ 95\ caracteres\ ASCII\ imprimibles:\n" & @CRLF & _
"\ ! \" \# \$ % & ' \( \) \* \+ , - \. /\n" & @CRLF & _
"0123456789 :;<=> \? @\n" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ \[ \\ ] \^ _ `\n" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz { \| }~ \~ \n" & @CRLF & _
"1\.2-Algunos\ ASCII\ extendidos: áÁàÀäÄâÂéíóú\nñÑ\tÿ\" & @CRLF & _
"2-Algunos\ Unicode\ no\ no\ ASCII:∫∬∭∰\u2230"
Local $sString = "1-ASCII:" & @CRLF & _
"1.1-Los 95 caracteres ASCII imprimibles:" & @CRLF & _
" !"#$%&'()*+,-./" & @CRLF & _
"0123456789:;<=>?@" & @CRLF & _
"ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz{|}~~" & @CRLF & _
"1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú" & @CRLF & _
"ñÑ ÿ" & @CRLF & _
"2-Algunos Unicode no no ASCII:∫∬∭∰∰"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")