use strict;
my $str = '1-ASCII:
1.1-Los 95 caracteres ASCII imprimibles:
!"#$%&\'()*+,-./
0123456789:;<=>?@
ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_`
abcdefghijklmnopqrstuvwxyz{|}~~
1.2-Algunos ASCII extendidos:áÁàÀäÄâÂéíóú
ñÑ ÿ
2-Algunos Unicode no no ASCII:∫∬∭∰∰';
my $regex = qr/(?mixs)1-ASCII:(?#Literales ASCII)\n
1\.1-Los\ 95\ caracteres\ ASCII\ imprimibles:\n
\ ! \" \# \$ % & ' \( \) \* \+ , - \. /\n
0123456789 :;<=> \? @\n
ABCDEFGHIJKLMNOPQRSTUVWXYZ \[ \\ ] \^ _ `\n
abcdefghijklmnopqrstuvwxyz { \| }~ \~ \n
1\.2-Algunos\ ASCII\ extendidos: áÁàÀäÄâÂéíóú\nñÑ\tÿ\
2-Algunos\ Unicode\ no\ no\ ASCII:∫∬∭∰\u2230/xap;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}