$re = '/\$\d+(?:\.\d+)?/';
$str = '[X: $1.19] [Y: $5.29] [Z 999/1000]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);