#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " (.+)(\n( [^ ].+\n)+)"
Local $sString = " ARTHUR " & @CRLF & _
" Yeah. I mean, that's just--" & @CRLF & _
"" & @CRLF & _
" SOCIAL WORKER" & @CRLF & _
" Does my reading it upset you?" & @CRLF & _
"" & @CRLF & _
"He leans in." & @CRLF & _
"" & @CRLF & _
" ARTHUR" & @CRLF & _
" No. I just,-- some of its " & @CRLF & _
" personal. You knowome ?" & @CRLF & _
" SOCIAL WORKER" & @CRLF & _
" I understand. I just want to make " & @CRLF & _
" sure you're keeping up with it." & @CRLF & _
"She slides his journal back to him. He holds it in his lap."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")