using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (.+)(\n( [^ ].+\n)+)";
string input = @" ARTHUR
Yeah. I mean, that's just--
SOCIAL WORKER
Does my reading it upset you?
He leans in.
ARTHUR
No. I just,-- some of its
personal. You knowome ?
SOCIAL WORKER
I understand. I just want to make
sure you're keeping up with it.
She slides his journal back to him. He holds it in his lap.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}