package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` (.+)(\n( [^ ].+\n)+)`)
var str = ` ARTHUR
Yeah. I mean, that's just--
SOCIAL WORKER
Does my reading it upset you?
He leans in.
ARTHUR
No. I just,-- some of its
personal. You knowome ?
SOCIAL WORKER
I understand. I just want to make
sure you're keeping up with it.
She slides his journal back to him. He holds it in his lap.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}