package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Example(\d+)`)
var str = `Example1 another text 123 Example2 text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}