import re
regex = re.compile(r"(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\)|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|\{((?:[A-Za-z])+)\})(?:(\+|\-|\*|\/)(?:(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\))|(?:(SUM|AGV|ABS)\(\{((?:[A-Za-z])+)\}\,\{((?:[A-Za-z])+)\}\))|(?:\{((?:[A-Za-z])+)\})))*", flags=re.MULTILINE)
test_str = ("ABS({AbcdefgF},{AbcdefgF})+SUM({AbcdefgF},{A})\n"
"SUM({AbcdefgF})+SUM({AbcdefgF})\n"
"{AbcdefgF}+{AbcdefgF}-{AbcdefgF}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")