// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<meta name="generator" content="Subrion CMS ([\d\.]+)*"#).unwrap();
let string = "<meta name=\"generator\" content=\"Subrion CMS 3.3.4.10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}