re = /[0-9a-fA-F]{8}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{4}\-[0-9a-fA-F]{12}/m
str = '6a2f41a3-c54c-fce8-32d2-0324e1c32e22'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end