package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:7\d{10}|421\d{9})$`)
var str = `71234567890
421123456789
7123
42112345678910`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}